Large Area Imagery Collection & Processing
Standard Operating Procedures

Version 2.0

Contributing Authors
Dr. Stuart Sandin¹
Dr. Brian Zgliczynski¹
Lindsay Bonito¹
Clinton Edwards¹
Nicole Pedersen¹
Christopher Sullivan¹
Dr. Yoan Eynaud¹
Vid Petrovic²

¹Scripps Institution of Oceanography
UC San Diego

²Computer Science and Engineering
UC San Diego

www.100islandchallenge.org
www.sandinlab.ucsd.edu
# Table of Contents

1. 100 Island Challenge Overview 1

2. Large Area Imagery Overview 9

3. Field Collection Standard Operating Procedure 13
   3.1 Mosaic Rig Assembly
   3.2 Camera Preparation & Settings 21
   3.3 Entering the Water with the Cameras 24
   3.4 Establishing or Resurveying a Site 25
   3.5 Plot Setup 27
   3.6 Image & Measurement Collection 28
   3.7 Clean Up & Camera Maintenance 33
   3.8 Data Download 33
   3.9 Metadata Organization 35

4. Technical Processing Standard Operating Procedure 37
   4.1 Overview of Agisoft Photoscan Pro 37
   4.2 Computer Hardware Requirements 37
   4.3 Project Setup 38
   4.4 Create the Model 39
   4.5 Make an Orthophoto 40
   4.6 Export Products 42

5. Ecological Processing Standard Operating Procedure 45
   5.1 Overview 45
   5.2 Required Software and Hardware 45
   5.3 Photoshop Setup 46
   5.4 Plot Setup 47
   5.5 Image Reference Mapping 50
   5.6 Tool Presets 51
   5.7 Segmentation and Classification 52
   5.8 Exporting Data 53
   5.9 Analyzing Data 55

6. Appendix 57
   Appendix I: Field Collection - Single Camera Setup
   Appendix II: Field Collection - Mosaic Hardware
   Appendix III: Field Collection - Plot Metadata Sheet 59
   Appendix IV: Field Collection - Dive and Navigation Metadata Sheet 60
   Appendix V: Field Collection - Calibration Sheet 61
   Appendix VI: Field Collection - Calibration Target 62
   Appendix VII: Ecological Processing - Grid R Code 63
The Scripps Oceanography 100 Island Challenge
Developing conservation targets for coral reefs globally

Principal Investigator: Stuart Sandin (ssandin@ucsd.edu)
Co-Principal Investigator: Jennifer Smith (smithj@ucsd.edu)
Project Coordinator: Brian Zgliczynski (bzagliczy@ucsd.edu)

Website: 100IslandChallenge.org
SUMMARY

Coral reefs cover less than 0.1% of the Earth’s surface, yet are estimated to support greater than 25% of marine biodiversity. For the hundreds of millions of people living adjacent to coral reefs, this productive ecosystem provides important shoreline protection and critical food security. Alarmingly, a combination of local human influences and global climatic changes are altering the structure and functioning of many reef ecosystems.

For years, our team at Scripps Institution of Oceanography has been working to establish a regional scale perspective of coral reef health, investigating how reefs are structured, how they change over time, and how we can better manage them in the face of global change. To accelerate this crucial effort, we have established a large-scale field campaign across the tropical Pacific and beyond that will generate critical data about reef ecosystems through time.

By using a collection of survey technologies coupled with ecological theory and quantitative models, we will gain important insights into the relative condition of coral reefs from across locations, using large-scale geographic scope to provide context for comparisons across locations. By developing a rigorous and repeatable sampling protocol, especially with the inclusion and sharing of high-resolution data (fish, benthic, oceanographic) and novel reef visualization products (i.e., large-area ‘photomosaics’), we can inform and educate managers and other stakeholders about how their coral reefs function and what is needed to ensure that reefs persist into the future.

Figure 1. Spatial scales of benthic observation across the coral reefs of the tropics. Benthic interactions are noted at the 0.1-1 cm scale, organismal identifications are recorded at the 10 cm – 1 m scale, distribution of organisms is recorded in photomosaics at 100s m² scale, sites are embedded within the island scale (10s – 100s km²), and all are contained within the regional scale (1 – 10 million km²).
BACKGROUND

As a consequence of global coral reef decline, new techniques to slow, halt or reverse patterns of degradation have become both a research objective and a management priority. Comprehensive documentation on the causes of coral reef decline indicates that natural and anthropogenic stressors, such as major storms, pollution, and overfishing, interact with global change stressors such as warming and ocean acidification to cause reef loss. Yet we lack clear information regarding the specific pathways involved in these declines.

Several important questions emerge that require novel approaches to answer:

(i) How do global stressors (warming, ocean acidification, El Niño) affect coral reefs that experience different natural and anthropogenic conditions? Are remote reefs without human populations better at combating global stressors than reefs adjacent to human settlements?

(ii) Can local management activities (i.e., of fisheries, water quality, watersheds) enhance the ability of a reef to withstand global stress events? Or if not, can these activities increase resilience by facilitating recovery?

(iii) Can active intervention (cultivation of resistant or weedy coral species and transplantation, restoration of herbivore populations, etc.) help to mitigate global impacts on coral reefs?

Without clear insights into the mechanisms of change within a coral reef community, it is impossible to resolve debates regarding the most effective means to manage a reef for increased community health.

RESEARCH PLAN

The goal of this study is to conduct a large-scale natural experiment, investigating the independent and interactive effects of oceanography and human activities in affecting the structure and dynamics of coral reef communities. The natural experimental design uses islands as statistical replicates, as we select focal islands and reefs to span a diversity of combinations of human activity, oceanographic conditions (principally temperature and nutrient delivery), and island geomorphology. Critically, we are controlling for within-island variables by conducting the core surveys within the same habitat type – leeward, forereef habitat at 7-15m depth.

We employ a collection of standardized approaches to quantify the structure and the workings of each coral reef community. A summary of the methodology follows:

- **Fishes.** We use underwater visual census approaches to enumerate the density, size structure, and species composition of the fish assemblage at each reef. The surveys enable us to quantify critical elements of the size structure, trophic structure, and species diversity. Further, by using techniques of ecological and
fisheries science, we provide estimates of potential fisheries production, building off complementary efforts of life history analysis from our group and others.

- **Corals and algae.** We use photographic survey techniques to describe the benthic composition from each reef. Photoquadrats are collected to provide raw data on the percent coverage, species composition, and physiological health of corals, algae, and other benthic taxa. Further, we employ novel approaches of underwater large-area ‘photomosaic’ technology (Figure 1) to document the spatial structure and competitive dynamics of benthic taxa. Our design includes two surveys (separated by 2-3 years) for each site. By re-visiting exact locations and replicating mosaic photography, we have the unprecedented opportunity to track the dynamics of individual corals and patches of algae. In particular, with advanced image analysis we can track how a reef community changes, addressing questions of coral growth, death, and competition \((i – iii)\) that are currently unresolved.

- **Oceanographic context.** We use remotely-sensed products (i.e., satellite-derived data, wave models from buoy data) to document core descriptions of the oceanographic context of each island. We will complement these data with a subset of \textit{in situ} data, especially collecting temperature data and collating other data collected by regional partners.

- **Human dimension.** We use a collection of data sources to capture key elements of the human dimension of each island. These data include basic metrics of human population density and distribution, transportation network, and infrastructure. Where available and reliable, we include critical elements of governance structure, legal guidelines, and compliance patterns. We work in concert with the SocMon Pacifika program and other regional partners.

By combining these image-based data with reliable information about the composition of the fish community, the general oceanography, and the human population dynamics at each location, we can elucidate the conditions that are more (or less) conducive to the maintenance of growing and so-called "healthy" coral reefs. These data are becoming increasingly important as the years 2015-2016 represent the world's largest coral bleaching event ever documented as a result of combined El Nino and global warming.

**Applications for conservation and management**

By linking the fates of these reefs to the oceanographic conditions and to the local activities of people, we will be able to start understanding cause-and-effect pathways for reef change. Local-scale marine managers consistently seek information on the "state" of their coral reef, looking for regional comparisons to help guide local management. By making the data that describe each reef readily available and easy to visualize, there is a terrific opportunity to increase the dialogue between the science and management communities, as well as among managers looking for tangible information to improve their self-management.
Working side-by-side with regional managers and partners in local Nongovernmental Organizations (i.e., OneReef, the Nature Conservancy, Conservation International), we will expand the scientific insights into the state and future of their reef areas.

VISION AND CONCEPTS

Why is this important?

The Scripps 100 Island Challenge has been designed to fill a critical hole in both the science of coral reef ecology and the practice of coral reef management. In terms of science, the 100 Island Challenge provides a novel and comprehensive approach to learn about regional and global patterns of reef health. The majority of research in coral reef ecology is conducted at a limited number of sites on the planet, most frequently near to the handful of popular field stations in the tropics (i.e., Jamaica, Moorea, Lizard Island [Australia]). While this work has been important to advance our knowledge about the basics of the biology of organisms on coral reefs, it is much more challenging to learn about regional and global patterns of ecology when studying just one location.

In terms of management, the 100 Island Challenge will offer the scientific insights for conservation and management professionals to insightfully design strategies to maintain (or improve) reef health. In most cases, resource managers work with only a limited amount of information about the resources that they are managing. Even with the engagement of a team of scientists working at their location, these managers may be constrained to a very limited scope of information and insights. Very often, the solutions to management problems come from examples and insights gained at comparable locations that may be far abroad.

Our research effort will produce consistent and inter-comparable data and analyses that will enable reef managers to meaningfully contextualize the structure and happenings of their reef. The science will be developed with a regional and global perspective – considering factors like what makes particular locations special and what opportunities could be capitalized upon based on observations at other sites. By working with partners in each location, the research team will provide the tailored scientific advice through personal discussions that is too often ignored as a priority by coral reef scientists.

Finally, the data themselves will be accessible for consideration by individuals at all training levels. Large-scale photomosaics will be collected from each location and will be shared through public portals, online or through digital document delivery, for locations with limited internet bandwidth. As such, a manager will be able to see their reef and as well as the reefs of partner sites that may be hundreds or thousands of kilometers away. Learning by seeing has a value that should not be under-appreciated.
**What results do we hope to achieve?**

The 100 Island Challenge is founded on the understanding that solutions to the world’s environmental problems will not come from ‘ivory tower science’ or prescriptive ‘silver bullet’ strategies. There are thousands of coral reefs embedded within hundreds of human cultures, economies, and geographies, and the problems and potential solutions reflect the intricate complexity of these coupled human-natural systems. The value of science is in providing novel and generalizable insights to local resource users and managers about what is known, unknown, and unknowable about the workings of the natural environment in each setting, empowering the intellectual strengths of the users themselves. We view this project as catalytic in broadly expanding the knowledge base and insights of the broad community of environmental ‘soldiers’, sharing the capacity of the academy with the many who often reside in professional space that is overlooked by the scientific community.
Large Area Imagery Overview

Introduction

The Sandin Lab at The Scripps Institution of Oceanography uses high-resolution imagery collected by divers in situ to create detailed 3D and 2D models, or photomosaics, of the benthos. Photomosaics are composite images created from the fusion of 100’s to 1000’s of individual overlapping images. This technique can be used to create digital representations of large areas (100’s of square meters) of the benthos. Parallel to photoquadrat survey methods, photomosaics can be used to provide snapshots of the percent cover, species composition, and physiological health of corals, algae, other benthic taxa and structural complexity. However, when applied to large areas photomosaics also allow accurate characterization of the spatial structure and competitive dynamics of benthic organisms analogous to the visual information provided through satellite based-surveys of terrestrial communities. Importantly, when repeated over time large area photomosaics allow detailed investigations of change at the level of the individual organism as well as providing a rich photographic archive and data source for exploring ecological processes on coral reefs. A major benefit of this approach, especially when applied to large areas, is that several different data types can be collected through a single field method, reducing operational complexity and dive time, while also providing a permanent record of metrics that are otherwise collected in situ. Importantly, these models serve as digital archives that allow researchers to virtually revisit reefs to collect new data types and ask new ecological questions.

There are a wide variety of approaches that can be used to collect, create, manipulate and extract data from photomosaics. Here, we outline an approach which allows for the collection of highly replicated and taxonomically refined data at the level of the individual. Ultimately, while choices of plot size, camera type and underwater effort have been tailored to produce data of sufficient quality for our core goals, these methods will provide robust data for a variety of questions.
Image collection

The visual detail captured by photomosaics is a result of the quality of the individual images used to create the composite model. The detail of individual images is largely a function of the type of camera used and the distance from the substrate at which the image was taken. Larger full-frame cameras take higher quality images, but are bulkier, more difficult to use, and more expensive compared to lower quality devices such as GoPro. Similarly, images taken closer to the substrate will tend to have higher detail, yet will cover much less area of the reef and contain less overlap between adjacent images at the same given height from the bottom. As it is necessary to have multiple views of each portion of the reef and high overlap between these images, the choice of camera and height of image collection is critical. Consequently, the spatial extent of the imaged area is based on decisions of desired image quality and dive safety. The plot size (100m²) and camera type recommended here (Nikon D7000), as well as height above the bottom (1.5m) at which we recommend collecting images, has been experimentally determined to maximize replication of coral colonies (100s-1000’s per plot) while allowing detailed taxonomic (genus or species level) designations to be made. Two SLR cameras are used and set to fixed focal lengths of 18mm and 55mm. The wide-angle view of the 18mm camera allows for the high overlap between adjacent images, which is necessary for model creation, while higher-resolution images from the 55mm camera allow for detailed taxonomic designations to be made. To facilitate image collection and reduce the likelihood of missing imagery, we have equipped our camera frame with a series of instruments (level, compass, dive computer) to help divers keep track of their position inside the plot, distance from the benthos and time spent imaging.

Model Creation

Photomosaics include both the 2D top-down views of the reef, termed orthoprojections, and the 3D models from which they are derived. We use the commercially available Structure from Motion (SfM) based software, Agisoft, to fuse raw imagery from the 18mm camera and create 3D photomosaic models, also known as point clouds. The software relies on multiple highly overlapping images of the same portion of the substrate to recreate the 3D scene. The creation of 3D models is a computationally intensive process and this guide outlines the software settings which we have experimentally determined to maximize photomosaic quality and minimize run time (see Technical Processing SOP, Step 2). While Agisoft can be used to create the orthoprojections via ‘meshing’ of the 3D point cloud, the output products are prone to error, especially in high relief areas. Using custom software designed by the Computer Science and Engineering Department at UC San Diego (Viscore), we create orthoprojections directly from point clouds, as this produces the most geometrically accurate representation of the scene (for further details on orthoprojection creation please contact Nicole Pedersen, nepeders@ucsd.edu). Importantly, the creation of orthoprojections and downstream extraction of spatially accurate data relies on two critical pieces of information collected in the field during image collection: scale and depth. Scale, whether derived via hand measurements between markers visible inside
the plot, or by the placement of scale bars within the plot area, is necessary to scale both the 3D and 2D models as well as report the associated error of the model. Similarly, to correctly orient the orthoprojection, it is essential to record the depth of at least six targets visible in the plot; however, the greater the number of depth measurements the more accurate the orthoprojection. Further, orthoprojections are enhanced by the collection of raw imagery which is parallel to plane of projection, therefore a level has been affixed to the camera frame to provide divers with a reference when collection imagery. However, in some instances high relief or dramatic depth gradients within plots may necessitate holding the camera off-level to collect images of adequate quality (see Field Collection SOP, Step 6).

The rest of this guide features step-by-step instructions for the implementation of the standard operating procedure used by the 100 Island Challenge team. We outline the tools and procedures for the collection and creation of photomosaics as well as the necessary steps for the extraction of ecological data from them. Should you have any questions on any of the content included here please contact Brian Zgliczynski (bzwgliczy@ucsd.edu).
Large Area Imagery Field Collection
Standard Operating Procedure

Please contact either Lindsay Bonito (lbonito@ucsd.edu) or Christopher Sullivan (cjsullivan@ucsd.edu) if you have any questions regarding the Field Collection procedure.

3.1 Mosaic Frame Assembly and Camera Installation

The tools and equipment used to conduct photomosaic surveys consists of two SLR Nikon D7000 cameras mounted to a custom frame (Figure 2). The camera used to generate processed photomosaic imagery uses a wide-angle lens (18mm) to ensure high overlap among adjacent images. The second camera uses a longer focal length lens (55mm) to capture images with sub-cm spatial resolution.

Figure 2. Schematic of mosaic camera system including digital SLR camera and frame.
Materials for Mosaic Rig Assembly

<table>
<thead>
<tr>
<th>QTY</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Nikon D7000 SLR camera and AF-s DX zoom-Nikon ED 18-55mm F3.5-5.6G 11 autofocus lens</td>
</tr>
<tr>
<td>2</td>
<td>Ikelite underwater camera housing for Nikon D7000 including: modular 8-inch dome, modular 3.5-inch lens extension, SLR-DC underwater camera tray and handles</td>
</tr>
<tr>
<td>4</td>
<td>High-capacity storage SD cards</td>
</tr>
<tr>
<td>2</td>
<td>Outer frame pieces constructed of ½” dolphin gray marine grade Starboard</td>
</tr>
<tr>
<td>6</td>
<td>Delrin machined and tapped for 3/8” 16 thread support braces</td>
</tr>
<tr>
<td>2</td>
<td>Camera tray mount pieces constructed ½” dolphin gray marine grade Starboard</td>
</tr>
<tr>
<td>2</td>
<td>Camera slides and mounts constructed of HPDE</td>
</tr>
</tbody>
</table>

Below are different views of the mosaic rig fully assembled with the optional equipment attached (level, dive computer):
1. **Assemble frame.** Using 12 Stainless Steel Flat Head Phillips Machine Screws (3/8” – 16 thread, 1-1/2" length), connect the two sides of the frame. 4 of the frame columns will already be assembled to the camera plates. The camera plates (one includes the laser mount) will already be assembled and ready to be attached to the frame. Lasers were previously used in surveys but are now optional and not in standard protocol. See camera mounting plates below:
2. **Attach dome to dome port.** Clean the housing, dome, and dome port thoroughly with Kimwipes. Grease both o-rings with silicon lubricant and place the larger o-ring labeled “thread side” around the dome port closest to the threaded area. Place the smaller o-ring on the opposite side. Screw the threaded side of the dome port to the dome so that base of dome port seals against base of dome.

Ensure that you completely seal the dome port to the dome, as the thread has a very tight fit to the dome, and it takes quite a bit of force to completely seal. We have provided a tension strap to assist in this process.
3. **Attach dome to housing.** Seat the dome into the housing and attach with the 4 port locks. Be sure to secure all 4 port locks in locked position. Ensure that locks ‘click’ into place.

4. **Attach handles and white camera mounting plates to housing.** First, screw the housing handle to the housing using 2 black plastic washers and flathead machine screws. Next, attach the white camera mounting plate to the bottom of the housing handle plate using the 4 Camera Mounting Plate Screws. *Make sure that the silver buttons are facing away from the housing and that the hole in the white mounting plate lines up with the single hole in the handles.*
5. **Place cameras inside housings.** Be sure to clean the housing thoroughly with Kimwipes before placing the large o-ring on the back housing panel. Grease the o-ring with silicon lubricant and place the o-ring to seal the housing.

   a. **Open the housing, carefully opening each Lid Snap.** Lid Snaps have a Lock. To open, push Lid Snap Lock forward and lift as shown. Keep pressure on each Lid Snap so it does not fly open quickly.

   ![Lid Snap Opening Diagram]

   b. **Attach the Hotshoe and Camera Mounting Bolt.** Slide the Hotshoe Connector all the way forward onto the camera flash mount until it stops. Hotshoe Connector should be attached before the camera is secured with the mounting bolt. Position the camera and lens on the camera tray, and then secure it with the mounting bolt which threads into the camera’s tripod socket. Use a flathead screwdriver (recommended) or coin to tighten the mounting bolt so the camera bottom is flush against the tray. The Leveling Screw is factory preset and does not need to be adjusted.

   ![Camera Mounting Bolt Diagram]
c. **Install Camera in Housing and Close Housing.** Before installing the camera, make sure housing control levers are out of the way. Pull out on the controls in the front section of the housing, or point them forward away from the back. This will allow the camera to slide in easier. Once the camera is installed and the lid snaps have been closed, return the controls to their operating position.

![Diagram showing housing and camera installation](image)

---

**d. Conduct final checks before loading into frame.**

i. **CHECK** each housing control’s operation.

ii. **CHECK** the main housing o-ring seal (should appear as a dark line around the housing back).

iii. **CHECK** Lid Snap Locking Tabs. Make sure they are flipped up.

---

6. **Install cameras in mosaic rig.** Slide each camera housing into the mosaic frame. BE SURE to install the “bottom” camera first or you won't be able to tighten the housing to the plate with the wing nut. Line up the white camera plate hole to the holes on the frame. Usually it should line up around the 2nd or 3rd hole from the front. However, you want to be sure each camera is at an equal distance from the front of the frame. Using the short wing nut for the “bottom” camera, tighten the wing nut until it is finger tight. Repeat this process for the second camera, using the long wing nut.

![Diagram showing camera installation in mosaic rig](image)
7. **Attach instruments** (*optional - level, compass, dive computer*). Use screws to install the level to the mosaic frame. Use zip ties to attach the compass and computer. Be sure these are on the correct side, such that you are looking at the back of the housings while diving with the frame.
3.2 Camera Preparation & Settings

We use an optimized set of camera settings that are robust to the dynamic environments that mosaics are typically captured in and require minimal user intervention during image capture. It is necessary to recheck all menu settings each day as they can be changed accidentally. The steps below outline how to access and program all necessary settings through the default menus, however all items have also been made accessible through the customized “My Menu” to minimize the steps needed to check and program camera settings.

General Camera Prep
1. Cameras batteries are fully charged
2. Memory cards clear. *Cards can be formatted in camera*
3. Clean housings
4. Grease O-rings
5. Viewfinder is taped. This blocks sunlight from entering camera, which can disrupt proper function of the internal light meter.

Nikon Camera Body Settings
1. Set focus dial on Camera Body to **AF**
2. Set shooting mode dial is set to **P**
3. Set release mode dial (the dial below shooting mode dial) to **S**
Nikon Lens Settings
1. Set SLR 1 zoom lens to 55mm
2. Set SLR 2 zoom to 18mm
3. Set focus switch on Lens to A
4. Set VR to Off

Nikon Menu Settings
1. Verify live view is off (finger dial, top right corner of view screen). If live view is on you will be unable to access many of the menu settings

2. Autofocus settings
   a. Top screen is in AF-C mode. To change push AF button and spin back finger wheel
   b. Autofocus settings:
   Menu -> Custom Shooting Menu -> Autofocus menu ->
   a. a1 -> Focus
   b. a2 -> Focus
   c. a6 -> AF11 11 points
   c. Set top screen symbol to a single central point
      a. To change push AF button and spin front finger wheel
3. ISO sensitivity settings:
   Menu -> Shooting Menu -> ISO sensitivity settings:
   a. ISO Sensitivity = 400
   b. Auto ISO Sensitivity control = ON
   c. Maximum sensitivity = 3200
   d. Min shutter speed= 1/200 s

4. File settings
   a. Menu -> Shooting Menu-> Image quality -> JPEG fine

5. White balance: Auto
   a. Menu -> Shooting Menu -> White Balance-> Auto1

6. Interval timer settings
   a. Menu -> Shooting Menu -> Interval timer shooting
   b. Choose start time -> Now
   c. Interval -> 00:00':01'
   d. Select interval x no. of shots -> 999x1=0999
   e. Start -> Off*
   *Turn the interval shooting on once you are ready to start swimming. The only way to stop the interval timer is to power off the camera

Are you ready to Mosaic?
Once system is assembled, check you can access all camera controls and menus.
- If you can’t access controls, it is usually due to one of the buttons being depressed, usually the shutter or live view buttons.
- If the flash is enabled you will not be able to access menus, look for the flash icon on the top screen.
- If you cannot resolve the issue, restart the camera.
3.3 Entering the Water with the Cameras

The goal of the photomosaic survey protocol is to safely collect images of benthic habitats of focal areas following safety standards identified by the host institution’s diving safety program. Once a focal site is identified, divers working as a 2-3 person team enter the water to set-up the mosaic plot and commence collecting imagery in the following manner (See Figure 3 for further clarification).

Image Collection Equipment

<table>
<thead>
<tr>
<th>Qty</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Mosaic rig</td>
</tr>
<tr>
<td>1-2</td>
<td>Dive Slate (Plot Metadata &amp; Calibration Grid) &amp; Road Map</td>
</tr>
<tr>
<td>6</td>
<td>Calibration targets</td>
</tr>
<tr>
<td>4</td>
<td>Calibration bars (2 targets mounted on pre-measured pole)</td>
</tr>
<tr>
<td>1</td>
<td>Transect Tape (30m)</td>
</tr>
<tr>
<td>4</td>
<td>Weighted reference floats (1lb)</td>
</tr>
<tr>
<td>2</td>
<td>Stainless steel stakes</td>
</tr>
<tr>
<td>1</td>
<td>two-part marine epoxy</td>
</tr>
<tr>
<td>1</td>
<td>mallet</td>
</tr>
</tbody>
</table>

Entering the Water

1. Enter water with dive gear only.
   a. Place frame into water, keeping the domes level and pointed directly down, submerging completely while divers in water inspect housings for leaks.
   b. Once the frame is submerged rotate the frame so that domes face towards the surface, remove any bubbles from housings and domes and check again for leaks.
   c. Both divers descend and establish site.

In the event of a flooding, all is not lost. The reservoir created by the domes gives you a few seconds to get the cameras out of the water. If domes fill with water, quickly remove the frame from the water with special care to keep it level. If the cameras do get in contact with water, it is imperative to remove the batteries immediately.
3.4 Establishing or Resurveying a Site

The establishment, geo-referencing and relocation of plots is a critical step in the collection and use of photomosaics, especially for sites that will be subsequently revisited. Regardless if a plot is being established or revisited, it is important to take an accurate GPS point and record in the metadata any key features that might facilitate relocation in subsequent surveys. When conducting repeat surveys, it is critical to resurvey the entirety of the original plot area using permanent markers or imagery from previous year’s surveys as a guide.

Establishing a New Site

1. Plot Selection Characteristics
   a. Minimize depth variation in the plot*
   b. If you are not installing permanent markers it is helpful to place center markers near readily identified features to aid in plot relocation.

*Subject to change based on trip logistics and site characteristics

2. Setting the Reference Stakes
   a. Reference stakes consist of two 18" long 3/8" diameter 316 stainless steel stakes with sharpened tips driven into the substrate and allow the plot to be relocated and accurately reimaged during subsequent visits. Establish the first stake in an appropriate location (i.e. high point on reef and secure).

   b. While the first member of the dive team marks the site with the reference stake, the second diver uses a transect tape and swims out horizontal to shore along the 10m isobath. Once the diver reaches 10m, a second stake is driven into the substrate to mark the central axis of the mosaic plot (Figure 3).

   In some instances, a suitable location for stake installation will not be available at exactly 10m. If this occurs, please install the stake at the next further location along the transect line.

   c. Be sure to secure the base of the stake using a quarter to half a stick of 2-part epoxy putty (i.e., Aquamend).

   d. Affix a locking nut to the first stake prior to deployment. This stake will serve as the reference stake, to designate the “left” side of the plot, or starting point. Take a GPS waypoint from this stake.

   e. Take an accurate GPS point at the reference stake with the lock nut. This is best done at the end of the dive, where one diver hovers over the stake, and the second diver surfaces to record the GPS position using a hand-held GPS unit. This can be accomplished by mounting a GPS to a float in a waterproof housing or coordinating the collection of a waypoint with the surface support vessel.
Recovering an Established Site

1. Be sure to bring an extra slate with a color “road map” (see page 39, Make an Orthophoto) along with the old plot metadata to assist in the relocation of the mosaic plot.

2. Take an accurate GPS point at the reference stake with the lock nut. This is best done at the end of the dive, where one diver hovers over the stake, and the second diver surfaces to record the GPS position using a hand-held GPS unit. This can be accomplished by mounting a GPS to a float in a waterproof housing or coordinating the collection of a waypoint with the surface support vessel.

   **ALWAYS, regardless if plot is new or established, take an accurate GPS point from the reference stake**

---

**Figure 3. Diagram of mosaic plot setup outlining the preferred orientation of plot.**
3.5 Plot Setup

Different factors will influence the coordination of the plot setup, including dive team, dive time, and conditions. In a two-diver team (mosaic diver and supporting diver), generally, the supporting diver determines the orientation of the plot and places calibration targets, calibration bars, and reference floats per Figure 5. Both divers then take calibration photos. The mosaic diver then begins collecting images, while the other diver collects measurements, depths, and other associated metadata, carefully avoiding the mosaic diver.

1. Specialized calibration target markers are placed at each corner of the mosaic plot and next to each reference stake (Figure 4). The target markers are labeled with a unique identifier symbol, a unique number, and calibration borders to facilitate automated scale and color correction during post-processing.

2. The dive team then deploys calibration bars in each of the 4 quadrants of the mosaic plot (Figure 5). Calibration bars consist of 2 target markers affixed to a PVC pipe such that the center of the two tiles are exactly 50cm apart and are used to scale the final photomosaic.

3. Corner floats are deployed at the corners of the plot to provide a visual reference of the plot area during the survey. Floats should be placed >1m away from the corner markers (Figure 5). Be sure to place floats so that they are as close to the same height above the mean height of the plot (i.e. don't place on pinnacles or in holes).

Figure 5. Detailed description of mosaic plot setup identifying the placement of calibration markers and floats.
3.6 Image & Measurement Collection

Once the plot is established, one member of the dive team prepares the camera system for conducting the mosaic survey. To obtain continuous coverage of the reef floor within a plot, the diver operating the camera system uses the camera in interval timer mode while swimming a gridded pattern approximately 1.5m above the average depth of the plot at speeds sufficient to maintain maximum overlap between adjacent images (Figure 6). Images are simultaneously captured every second from both DSLR cameras. Depending on local conditions a single mosaic will take 40-55 minutes to collect and consists of approximately 2500 individual images per camera.

 Calibration (Divers 1 & 2)
The dive team works together to collect calibration images for each camera (18mm & 55mm) using the calibration sheet on the dive slate.

1. Turn the first camera on, turn on live view.
2. Take 6 angled pictures of the calibration with each camera separately (see figure below).
3. Review pictures and ensure quality of photos (i.e. in focus).
4. Repeat with second camera.

**Calibration: 6 angled photos**
Image Collection (Diver 1)

1. **Turn on the cameras and initiate the interval timers.** It is important to start the two cameras as close together as possible to facilitate timer restarting and minimize errant image collection during that time (see Restarting cameras, below).

2. **Signal the survey has started.** When you are ready to enter the plot wave hand in front of the two SLR cameras to create a signal that surveys have started. Due to the focus on the cameras and the proximity of your hand it may take a moment for the camera to focus. Make sure you hear the shutter to confirm that a picture has been taken and allow several pictures to be taken.

3. **Swim approximately 1.5m from bottom.**

   To aid swimming height set the reference floats so that they are at 1m above the bottom and use these to help guide your depth. It is best to swim 1.5m above the median plot relief (i.e. 1.5m above the average height of coral colonies, not the base of the colonies). At times, topographic complexity will require that you adjust your depth to maintain the same height above the bottom. When adjusting height, make sure to maintain proper camera altitude.

4. **Swim past the reference floats.** Using the reference floats as a guide, begin and end all swaths one body length past plot boundaries. It is important to image an area larger than the plot of interest to ensure that borders are not compromised (i.e. image distortion, sufficient image overlap, etc).

5. **Hold the camera frame level***. Make efforts to avoid collecting images of blue water or habitat outside of survey area when conducting surveys along steep habitat (i.e., drop-offs) or high habitat complexity (i.e., spur and groove).

   *In cases of steep slopes, it is important to minimize the amount of blue water in images by holding the camera parallel to the substrate. In these cases, you will be off level.

6. **Minimum one pass per meter;** for a 10 x 10m plot make at least 10 passes in each direction. If you have more time do more passes.

7. **Maintain a slow swimming speed.** This ensures ~90% overlap between successive images.

8. **Rotate body, not camera rig,** between swaths.

   **If you must pause taking pics for any reason:**
   1. Turn cameras off (to stop interval timer).
   2. Visually mark where you stopped (drop markers not recommended).
   3. Return to location where the camera was stopped.
   4. Starting 1-2 body lengths before the location you stopped at, resume interval timer.
**Restarting cameras**

1. The intervalometer takes a maximum of 999 images before it must be restarted. Listen for cameras to stop taking pics as you will exceed the 999 pictures during image collection. Additionally, it takes 16-17 minutes to take 999 images, so it is helpful to use your computer to keep track of the time elapsed since you started the intervalometer.

2. When the intervalometer stops, visually mark where the cameras stopped. The cameras will not end at exactly the same time so be sure to return to the location of the termination of the first interval timer.

3. Starting 1-2 body lengths before the location you stopped at, resume interval timer.

![Figure 6. Schematic of diver survey pattern to collect images of mosaic plot.](image)

**Plot Metadata Collection (Diver 2)**

Once the mosaic survey has begun, the second diver records the calibration target identification numbers and their associated depths. The identification numbers are also recorded for the calibration sticks as well. Although not required, the second diver may collect measurements of the plot area between target markers using the transect tape (dotted lines, Figure 7). It is good practice to describe the plot and any unique features that will aid in finding and resurveying the plot during future time points. If time allows, the second diver collects site photos of the plot area and close-ups of benthic taxa to serve as reference and taxonomic verification during post-processing.
Figure 7. Plot metadata sheet (full-size version in Appendix III).

**Plot Clean-up & GPS Waypoint Collection (Divers 1 & 2)**
Once the photomosaic survey is completed, the dive team works together to retrieve the markers and floats before returning to the surface. Prior to departing the site the dive team uses a GPS to mark the location of the start point permanent marker by snorkeling above plot using a handheld GPS or coordinating with a surface support team to collect the location of the plot.
Common issues While Diving

1. Steep slope
   It is difficult to operate the mosaic frame and equalize on plots that have too great of a depth change. In these situations, it is highly recommended to prioritize a single lawnmower swath parallel to the reef crest (no perpendicular passes). To compensate for the lack of an orthogonal swath conduct as many passes as possible (20+) & swim slowly to maintain high overlap.

2. Strong current
   Any current above 0.5kt can make operating the mosaic frame very difficult. It is advisable to check local tides and familiarize yourself with local current patterns during dive planning or site selection. A quick surface swim at each site to gauge the current is also advised. In some cases, it may still be possible to dive in an elevated current using a single camera setup (Appendix I). If the team decides it is safe enough to complete a survey within the team’s skills and comfort level it is recommended that the team proceed with the single camera set up.

3. Strong surge
   Any surge above 3’ can make operating the mosaic frame very difficult as it requires the diver to keep the camera frame in place along the axis of the survey swath while the diver moves back and forth with the surge. In these situations, it is again advised to use the single camera set up (Appendix I). If you are unable to judge the strength of the surge until it is too late and have the full mosaic rig at depth, (if you feel it is safe) conduct a single lawnmower swath parallel to the predominant swell direction (to help alleviate overall fatigue).

4. Interval Timer Issues
   At times the interval timer may stop before the 999 image sequence completes, or may take images at irregular intervals for a number of reasons, including the following:
   a. The lens may be having trouble focusing. Check the dome for bubbles or adjust swimming speed or distance from the bottom to facilitate the camera to focus. If problem continues be sure to allow for more overlap during survey.

   b. Memory card issues. When the SD cards begin to fail, the interval shooting period lengthens to greater than 1 second, or stops completely. If this happens, switch cards if possible and flag that memory card so the appropriate staff can deal with the equipment back in the lab.

   c. If all else fails, turn the camera on and off. Select the menu button and reset the interval timer. In some instances, attempts to start the interval timer will not work. Repeating the steps to start the interval timer through the Menu function often resolves the issue.
3.7 Clean Up & Camera Maintenance

Camera Housing Care
At the end of every dive day, the mosaic rig needs to be rinsed off and the camera housings need to soak in fresh water for at least 5 minutes. If at all possible, under running water, depress every control button on each housing multiple times to work out any salt and sand that may have gotten trapped. Dry housings with clean towel prior to opening housings. Once cameras have been removed place housings in clean space (preferably in an air-conditioned room) and allow to air dry while digital imagery is downloaded.

*If you have sticky pushbuttons*
Soak the housing in a mild soap solution and operate the pushbuttons repeatedly while the housing is submerged. Dry the housing off and rub a small amount of silicone lubricant on the outsides of the pushbuttons. Operate the pushbuttons several times to work the lubricant in.

Dome & O-ring Maintenance
Once the dome has been attached to the dome port at the start of the trip, in most cases it can be left in place until the completion of the trip. However, if operating in high sediment environments or you find that the o-ring needs care, use the strap wrench to loosen the dome from the dome port. The seal between the dome port and housing should be checked on a regular basis to ensure a proper seal and port lock functioning.

Every day use a Kimwipe to clean the o-ring and surrounding area of the housing door. Re-lube the main camera body o-ring with a thin layer of silicone grease and be sure the area and o-ring is free of any small debris (i.e. hair, sand) before replacing cameras.

3.8 Data Download

Upon returning from field survey all image files are downloaded to 2 external storage devices (i.e., hard drives) using a folder naming convention consistent with the metadata recorded from each site. Separate digital files by specific camera (18mm, 55mm, or site camera) within the folder for each survey site.

**Downloading images**
1. File storage architecture is included with the external hard drives to store data. Structure is as follows:
   a. Create a folder for the trip (i.e. NLI_2018) ->
   b. Within the trip folder create a folder for each island (i.e. JARVIS) ->
   c. Within each island folder create a folder for each site where images were collected, that includes the date (YYYYMMDD) (i.e. JAR_02_20180305)->
   d. Within the site folder create the following folders: 18mm, 55mm, Site Photos
      i. Copy and paste these folders into each of the site folders you created.
2. Downloading images from camera storage cards:
   a. Make sure all hard drives are formatted to EX-FAT before using the drive.
   b. The Nikon camera puts images into successively numbered folders, each with 999 images.
   c. It will start renumbering images after image 9999 and will create a new folder after image 9999 (starting with image 0001) even if the folder containing image 9999 does not have 999 images (in order to prevent overlapping file names in a single folder).
      i. Pay attention to this number scheme when downloading as it could cause issues with image sequence. Do not combine images from the same dive into the same folder if the counter has restarted as this will corrupt the image sequence. However, if you do so, you can use the time stamp to correctly reorganize.
   d. Successive dives will often be in the same folder.
      i. Even if the time is not set correctly, you can use the time stamp and interval between the dives to separate the groups of images. Remember, images will always start with the calibration photos.
   e. Download to the corresponding site folders on the drive using copy and paste.
   f. After the transfer, backup to the alternate drive.
   g. After backup, format the memory card so they are empty the next day, as this will avoid any confusion locating the correct images the following day.
3.9 Metadata Organization

There are multiple types of metadata to record while collecting imagery, which needs to be recorded in a consistent manner. Please follow the organization and naming convention below for each type of metadata. All metadata sheets have been included in the Appendix, with printable sheets in the digital version.

Dive and Navigation Information
Throughout each dive day, be sure to complete the trip metadata form to retain a record of all GPS waypoints and tasks completed at each site. All GPS waypoints should be recorded in decimal degrees.

Mosaic Plot Metadata
Please fill out the datasheet completely and provide as much detail as possible. This may include drawings and locations of notable features throughout the plot (see Step 6).

Expedition & Site Names
Please follow the naming hierarchy developed to organize data (images, metadata, etc) below. Each piece of data should be labeled using the following hierarchy:

1. **Expedition** - Use a short name to distinguish expedition name. Generally, this code should represent the region where the work was completed (i.e. MHI = Main Hawaiian Islands or NLI = Northern Line Islands).
2. **Island** - Use a 3-letter code to distinguish island name. Use lookup table, do not create your own (i.e. MOL = Molokini; MOI = Molokai).
3. **Site_Date** - Use a 3-letter island code and numbering system to distinguish site name. This will include the island code again, the site number (or name in some cases) and the date (YYYYMMDD) (i.e. HAW_048_20160721).

The resulting database storage system structure:
MHI_2016\HAW\HAW_048_20160721\55mm
4.1 Overview of Agisoft Photoscan

Photomosaics are created and processed using Agisoft Photoscan Professional Edition, commercially available software which utilizes Structure-from-Motion algorithms to create 3D reconstructions from 2D images. Successful reconstruction requires >60% side overlap and >80% forward overlap between images. Model reconstruction is broken down into multiple stages, which require minimal user implementation. The first stage is photo alignment, which uses feature matching to determine the position and orientation of each image and results in the creation of a sparse cloud. This is followed by building a dense cloud, which uses the estimated image positions from photo alignment to construct a 3D dense point cloud. Additionally, the sparse cloud may be used to create a polygonal textured mesh as an additional reconstruction of the model. Finally, the textured mesh is used to create an orthophoto (referred to in Agisoft as an orthomosaic), which blends the raw images together into a single 2D image.

Here, Agisoft is used to create two main products, the 3D dense point cloud and the 2D orthophoto. The 3D dense point cloud will be used further for 3D visualization and creation of a 2D orthoprojection of the point cloud for further ecological analysis using custom developed software (Viscore). The 2D orthophoto from Agisoft is also used to create downstream products such as outreach materials and roadmaps for repeat surveys. The parameters used here to construct the orthophoto often results in reconstruction errors or “ghosting” within the orthophoto and is therefore not advisable for scientific data extraction.

4.2 Computer Hardware Requirements

Processing models in Agisoft with image sets containing thousands of high quality images requires a great deal of computing power. Agisoft takes advantage of graphics processing unit (GPU) acceleration for various reconstruction steps, and requires a large amount of memory with increasing numbers of images. Increasing the number of CPU cores and the quality and number of GPUs can significantly decrease processing time. For image sets of this size the recommended minimum computer hardware includes:

- High Speed 10 Core CPU
- Multiple high-end GPUs (i.e. NVIDIA 1000 series, quantity: 2-4)
- 128 GB RAM
- Solid State Drive (SSD)
4.3 Project Setup

The first step to creating a model includes loading all of the raw imagery into Agisoft Photoscan Pro. Most Image sets will contain extraneous images, such as calibration photos, landscape photos, and hand or fin signals. Mobile objects which obstruct the view of the benthos are detrimental to reconstructions, and landscape images with a large field depth can increase processing time. It is therefore advised to remove such photos before model reconstruction to improve model quality and reconstruction time.

1. **Organize Images** Find the raw imagery associated with the model you want to create and copy them into a folder following the naming scheme of Island code (3-letters)_Site_Date. Images used for model creation are those taken with the 18mm lens camera. Depending on the desired image quality, computer specifications, and time allowed for model creation, images from the 55mm lens can also be added. By aligning both image sets, information about camera position and direction for all images can be used to link together the individual images and the model during downstream ecological processing. If both image sets are used, keep the image sets from each camera organized as separate subfolders within the overall image folder. Open a new project in Agisoft Photoscan and save this project as a .psx (Photoscan Project) following the same format as the raw imagery (Island code_Site_Date).

2. **Filter Images** Filter out and remove any unnecessary images. These include calibration photos and landscape photos that are often at the beginning and end of each photoset. Be sure to look through all images and remove those containing hand or fin signals as well as the occasional landscape image within a sequence. Images containing a high degree of depth (i.e. blue landscape, looking meters down a slope) will slow down the reconstruction process and should be removed from processing.

3. **Upload Photos** To load photos into your project, use Workflow -> Add Folder and select the folder you created containing the raw imagery. Upload images in a single chunk, with each file as a single camera. 
*If you choose to add images from both cameras, organize the images within Agisoft as 2 camera groups within a single chunk. To add a camera group, right click on the chunks and select add camera group.*
4.4 Create the Model

Creating a model in Agisoft is a two-step process. The first step aligns the photos and creates a sparse cloud from the point matches. The second step then takes these alignments and builds a more detailed dense cloud. Both steps can be run together to reduce user interaction and can take anywhere from 1-6 days depending on the imagery, complexity of the model, and computer specifications.

1. **Align Images** Go to Workflow -> Align Photos
   a. Accuracy: High
   b. Generic Preselection: No
   c. Reference Preselection: No
   d. Key Point Limit: 5,000
   e. Tie Point Limit: 0
   f. Constrain Features by Mask: No
   g. Adaptive Camera Model Fitting: Yes

2. **Check Alignment**
   a. Check that your images have been properly aligned. It is not necessary that every image has aligned successfully, just ensure that the plot area of interest has been fully reconstructed.
   b. Check the size and position of the bounding box. For any further steps, only the area of the model that falls within the bounding box will be processed. Resize or move the bounding box to include the entire plot area of interest and crop any excessive (and often poorly reconstructed) points that fall beyond the bounds of the area of interest.
   c. Clean the sparse cloud. You can use the selection tools to filter out and remove any points that you do not want reconstructed.
   d. Disable any unnecessary images. If you aligned the model with redundant image sets (i.e 18mm images and 55mm images), you can disable an image set (often 55mm images) before reconstructing the dense cloud to help speed up processing and reduce memory requirements.

3. **Build Dense Cloud** Go to Workflow -> Build Dense Cloud
   a. Quality: High
   b. Depth Filtering: Mild
   c. Reuse Depth Maps: No
4.5 Make an Orthophoto

Agisoft can also be used to create an orthophoto, which is a 2D reconstruction using the raw images. The orthophoto is commonly used for visualization and creation of outreach material and road maps that will be used to find sites in the future. The orthophoto created using the following methodology contains inaccuracies, or “ghosting,” and is therefore not advisable to be used for extraction of scientific data. Alternative processing methods not described here which create a higher resolution mesh can help reduce spatial inaccuracies. Additionally, this method uses the markers to define the plane of projection, assuming all fall at the same depth. **Markers can be referenced in Agisoft if relative marker depths are known to project the orthophoto based on the plane of gravity.**

1. Create textured mesh
   a. Workflow-> Build Mesh...
      i. Surface type: Arbitrary
      ii. Source data: Sparse cloud*
      iii. Face count: Select custom, then type in 1,000,000)*
   *Alternatively the source data can be changed to the dense cloud or the face count can be increased to improve the reconstruction quality of the mesh and derived orthophoto.
   b. Workflow-> Build Texture...
      i. Mapping Mode: Generic
      ii. Blending Mode: Mosaic (default)
      iii. Texture size/count: 4096 x 1

2. Place Markers (Optional)
   a. Option 1: Calibration targets can be automatically detected using Tools -> Markers -> Detect Markers. Targets are circular 12-bit, and the tolerance can remain at 50. Automatic detection of markers takes approximately 1 second per image.
   b. Option 2: If Calibration targets are not used in the model, markers can be manually placed on the model. Right click on the marker area (i.e. dive weight, reference stake, etc.) and select create marker
   **Either the dense cloud or the textured mesh can be used to find markers manually.**
3. **Create Orthophoto (Orthomosaic)** Pay careful attention to the numbers and orientation of your plot markers. The sides and direction are important in creating an orthophoto that is oriented correctly and not a mirror image if you are using the markers to orient the orthophoto (i.e. looking from below rather than above).

   a. Workflow -> Build Orthomosaic
   b. Option A: **Projection Plane: Top XY**
      i. If no markers are used, or the camera was reliably facing in straight down with respect to gravity, you can use Top XY to define the projection plane. This will use the average facing angle of all images to define the projection plane.
   c. Option B: **Projection Plane: Markers**
      i. It is recommended to orient the markers like an XY axis, ordering the marker numbers from 0 to X for the horizontal axis, and 0 to Y for the vertical axis. Reversing the order of one of these axes will result in a mirrored orthophoto.
   d. Max Dimension (pix): 20000

   *If there is a lot of extra space beyond the plot markers, this number can be raised to increase image resolution, the goal is to export the image at a resolution of approximately 1mm/pix.*
   d. Double check the orthomosaic to ensure it is not a mirror image.

**The processes outlined above in Steps 2 and 3 can alternatively be processed together in batch to reduce the time needed to track progress and startup each individual step. To process multiple steps together, go to Workflow -> Batch Process, and add the steps of interest, changing to the same settings outlined above for each individual process.**
4.6 Export Products

By following the export procedures outlined below you can archive your project file and revisit later without having to re-run your model to collect reports, and parameters for archiving.

1. Export Orthophoto (Orthomosaic) Export the orthophoto as a .jpeg. The orthophoto can be used to create a variety of outreach materials, but again, is not recommended for scientific analysis.
   a. File -> Export Orthomosaic -> Export JPEG/TIFF/PNG...
   b. Set JPEG quality to 99
   c. Save as JPEG using Island code_Site_Date naming scheme

2. Export Dense Cloud The dense cloud is exported as a Stanford .ply. This point data will later be transformed into a format where it can be read using custom visualization and analysis software (Viscore). In addition to creating fly-through videos of the 3D dense point cloud, 2D Viscore can be used to make a orthoprojection of the dense cloud to be used for scientific analysis of the model.
   a. File -> Export Points
   b. Save as .PLY using Island code_Site_Date naming scheme
   c. Export Parameters
      i. Source data: Dense cloud
      ii. Point colors, point normals, and binary encoding checked

3. Export Cameras This file contains information on the location and orientation of each image (referred to as a single camera in Agisoft). This information is then used by Viscore for features such as overlaying the raw images over the dense point cloud or used to reference and display the higher-resolution images for point count features.
   a. Tools -> Export -> Export Cameras...
   b. Save as Agisoft xml file using Island code_Site_Date_cams naming scheme

4. Export Report (Optional) A report of model parameters can be exported containing information on level of image overlap, camera calibration, model reconstruction parameters, and processing time for different stages of reconstruction.
   a. File -> Generate Report
   b. Projection: Top XY
   c. Save as .pdf using Island code_Site_Date_Report naming scheme
5. **File Summary** There should now be 6 files or folders associated with each model.
   a. Island code_Site_Date.psx
      *Agisoft project file, opens model project*
   b. Island code_Site_Date.files
      *Agisoft project files folder, contains all data for Agisoft project*
   c. Island code_Site_Date.jpeg
      *Orthophoto*
   d. Island code_Site_Date.ply
      *Dense Point Cloud*
   e. Island code_Site_Date_cams.xml
      *Camera locations and orientations*
   f. Island code_Site_Date_Report.pdf
      *Processing report*
5.1 Overview

Ecological data is extracted from 2-D orthoprojections, created through custom developed visualization and analysis software (Viscore), using human-driven segmentation and classification. The orthoprojection is an orthorectified 2D projection of the 3D dense point cloud, oriented to the plane of gravity. Images are fully segmented using the software Adobe Photoshop by outlining all individual coral colonies with a Wacom pen tablet and filling each outlined area with a specific color corresponding to the appropriate taxonomic classification. These classifications are then exported from Photoshop as images and analyzed in R to extract a variety of metrics such as percent cover, abundance, size frequency distributions, and other spatial characteristics of coral communities.

Figure 8. Raw orthoprojection (left) before segmentation and classification (middle). The background is removed before export (right).

5.2 Required Software and Hardware

Adobe Photoshop
Wacom Intuos Pen and Tablet
Minimum Computer System Requirements:
    - 16GB RAM
    - Solid State Drive (SSD)
5.3 Photoshop Setup

First ensure that Photoshop is set up correctly. The useful windows to have open in Photoshop for digitizing are swatches, navigation, layers, and history. To add or remove windows go to the windows tab and check or uncheck the appropriate window.

1. Create a Swatch from Scratch

For segmentation and more importantly, classification, it is first necessary to create a set of ‘swatches’ with unique colors for each taxonomic designation.
   a. Clear any current swatches (alt+click)
   b. Add swatch color
      i. Click on foreground color icon
      ii. Change color selection to desired color. *It is recommended to start every set of swatches with pure black (RGB:0,0,0) for border tracings and pure red (RGB:255,0,0) for export fills.*
      iii. Click “add to swatch”
      iv. Name swatch for taxonomic designation
   c. Continue until all expected taxonomic designations have a swatch color
   d. Select the three line icon near swatches and save the swatch as an .aco file

2. Load Previously Made Swatch

While colors can be added or changed after the swatch has been created, it is imperative to maintain consistency in swatch application and swatches should be archived and shared across computers.
   a. Select the three-line icon near swatches (green box, right)
   b. Select Replace Swatches…
   c. Select .aco file containing swatches.
   Swatches should be made at the finest taxonomic scale, higher level taxonomic or functional groupings will be done in later steps.
5.4 Plot Setup

Before you begin, the first step is to define your tracing area, which is usually a 10m x 10m area. This is the total area that will be exported for further analysis.

1. **Create a new layer** (Ctrl+Shift+N) called posts.

2. **Mark all plot markers** Place a 100px diameter pencil dot on each of the six plot markers (dive weight, reference stake, or Calibration target).

3. **Determine scale** Use scaling features placed in your plot, either calibration targets (used as plot markers), calibration bars, or long measurements between plot markers to determine the pixels per meter of the image.
   a. Check that units are in pixels by going to Edit -> Preferences -> Units & Ruler
   b. Select the ruler tool (subset of Eye Dropper (I) Tool)
   c. Place your ruler from marker to marker
   d. Record the pixel value after L1 for the number of pixels between markers
   e. Repeat for all scaling features
   f. Average to find pixels per meter
   g. Determine pixel dimensions of desired tracing area
4. Set tracing area  Once you have determined pixels per meter, use the rectangular marquee tool to set your plot area.
   a. Select the rectangular marquee tool
   b. Change the style to fixed size

c. Enter in the pixel dimensions corresponding to the size of your plot area

d. Place selection box over desired tracing area. For plots planned as repeated surveys, place edge of selection area near or on a permanent reference to make it easier to place the same tracing area on a subsequent time point

e. Create a new layer called “10 x 10m” or other desired plot dimensions

f. Set foreground color to pure red

g. Select Edit -> Stroke
   i. 10 pixel width
   ii. Location: Outside
   iii. Mode: Normal
   iv. Opacity: 100%
5. **Make Grid (Optional)** Sometimes, a grid overlayed on the image can be used to aid in tracking tracing progress.

   a. Open R or RStudio and paste in code for Grid (see appendix VII)
   b. Change working directory to desired workspace
   c. Change picname
   d. Set `picture_w` equal to pixel width of image*
   e. Set `picture_h` equal to pixel height of image*

   *Image pixel dimensions can be found in Photoshop using Image -> Image Size

   f. Set `meter_pixel` to previously established scale of pixels/meter
   g. Highlight all lines and run, a .pdf with the entered picname should be created

   h. Drag .pdf into Photoshop
   i. Expand size of grid so that red lines align with the edges of the image
   j. To set the grid, hit enter. The grid is scaled so that each box is 0.5 x 0.5 m
5.5 Image Reference Mapping (Piclinks)

Before you begin digitizing, it is useful to map the images from the 55mm camera onto the orthoprojection so that you can easily reference these high-resolution images for assistance in tracing and classifications.

1. Find the high-resolution images and open the first image with a distinguishable plot feature (i.e. target maker or reference float).

2. In Photoshop, locate and zoom to the area represented by this image on the orthoprojection.

3. Create a new layer called Piclinks and use the pencil tool (B) (see 4.1 below for proper tool setup) to write the file number in center of the area represented by picture. Always rotate the Photoshop document (R) to align with the orientation of the raw images. Never rotate the raw images!

4. Use a pencil width so that writings are legible from further away (10px is recommended).

5. Draw an arrow between successively mapped images to indicate the direction pictures are advancing in.

6. Continue through the raw image sequence and map the images onto the orthoprojection. Depending on the swimming speed of the diver who collected imagery in the field, how often you map images (i.e. every 5 images, 10 images, etc.) onto the Piclinks layer will change. After mapping a given image, it is recommended to skip through successive images until all features visible in the first image are out of view before mapping the next image.

7. There should now be five layers associated with your file: Posts, 10 x 10m (or other designated plot size), Grid, Piclinks, and Background. Two additional layers should be added:
   a. Borders: used for all coral colony tracings
   b. Questions: extra layer for notes, progress notations, ID questions, and tracing questions
5.6 Tool Presets

Commonly used tools in Photoshop are the brush (B), eraser (E), gradient (G), and quick selection (W) tools. For some of these tools, the default settings are changed to ensure that all work is done using hard edged, non-transparent pixels. **While in most instances, any changed presets will remain on a single computer, they can revert to default settings after updates or computer restarts so it is important to regularly check tool presets and pay attention to pencil widths and pixel transparency when digitizing.**

1. **Brush Tool Presets** All tracing (i.e. segmentation) is done using the pencil subset of the brush (B) tool. **Before tracing, it is extremely important to check that the pencil settings are correct as incorrect settings can lead to systematic bias and potentially spurious results**
   a. Right click the brush icon to select the pencil tool
   b. Click on the folder icon to open the presets
      i. Shape Dynamics: unchecked
      ii. Smoothing: checked
      iii. Hardness: 100%
      iv. Spacing: checked and set to 1%
      v. Pencil size: 2 pixels. **Pencil size can be changed using the “[“ and “]” keys**

2. **Eraser Tool Presets** In many instances, it is easiest to make changes to tracings using the eraser tool. As with the pencil, make sure any changes are made using hard edges by ensuring the eraser is in pencil mode.

3. **Paint Bucket Tool Presets** Once border tracing of colonies is complete, use the predetermined swatches to fill the enclosed areas representing the various coral colonies with the color associated with the correct taxonomic designation. All fills are made using the paint bucket subset of the gradient tool.
   a. Right click the gradient icon to select the paint bucket tool
   b. Mode: normal
   c. Tolerance: 2
   d. Anti-alias: unchecked
   e. Contiguous: checked
   f. All Layers: unchecked

4. **Magic Want Tool Presets** The magic wand tool, a subset of the quick selection tool, can be used to select contiguous fills for editing.
   a. Sample size: point sample
   b. Tolerance: 2
   c. Anti-alias: unchecked
   d. Contiguous: checked
   e. Sample All Layers: unchecked
5.7 Segmentation and Classification

Now that you have your document setup and the raw images are referenced, you are ready to start tracing. It is highly recommended to use a systematic approach to segmentation and classification. Follow either the 18mm images to assist with tracing, or follow the grid using the 55mm images on the Piclinks layer as a guide.

1. Segmentation Trace all colonies found within the plot area as well as any colonies that intersect the plot border
   a. Operationally, the minimum colony size included in digitization is 3 x 3 cm. It is recommended to set the eraser size to a pixel size approximate to 3cm to use as a reference in determining whether an individual colony meets this minimum size requirement for digitization.
   b. All tracings should be done on the Borders layer using a 2px pencil that is pure black in color (RGB: 0,0,0).
   c. All live corals, erect macroalgae such as Halimeda and Caulerpa, and large benthic invertebrates (urchins, sea stars, clams, and sea cucumbers) are segmented and classified. Taxonomic classifications are made to the highest taxonomic resolution given limitations with image resolution.
   d. Digitization of other benthic organisms such as CCA and turf algae are not currently operationalized given the morphological complexity associated with these two organisms, which are often found as mixed assemblages (for more information please contact Clinton Edwards, clint@ucsd.edu).
   e. All live tissue (including bleached tissue) is included when tracing. Consult the high-resolution imagery to take care excluding areas of partial mortality from colony borders.
   f. An individual colony is defined as continuous patch of phenotypically identical polyps which share resources mainly through a live tissue connection*. In cases of partial mortality or fragmentation of a colony which produces multiple ramets, each ramet would be considered its own colony.
      *Exceptions are made for certain species known to fuse (i.e. Porites superfusa) or share resources without direct tissue connections (i.e. Lobophyllia).
   g. When segmenting algae groups, due to the difficulty of separating adjacent individuals, continuous clusters of individuals of the same taxonomic group are traced as a single patch.
   h. Large benthic invertebrates are traced similar to corals.
   i. All segmentation should be done at a standardized zoom level, depending on the resolution of your imagery. It is recommended to set a 0.5m x 0.5m grid box to the extent of your computer screen as the standard.
2. **Classification** Once all the borders of all organisms are traced, color swatches are used to fill in colony areas.
   a. Use the paint bucket tool to fill in the shapes with the swatch color corresponding to the correct taxonomic identification
   b. If more than just the area you want to fill gets filled, first check to make sure contiguous was checked. If it still fills a larger area, you likely have a gap in your borders that you need to find and complete

5.8 **Exporting Data**

The procedure outlined here is optimized for analysis of images using R. However, there are multiple pathways to export the data depending on your comfort level with scripting. In section 7 of this SOP we have provided code and instructions for analysis of separate layers using R.

1. **Crop to Export Area** Once digitization is complete, the document will need to be cropped so that only the plot area of interest is exported.
   a. Save the file as a new document with EXPORT added to the filename
   b. Turn off all layers except for 10 x 10m
   c. Select Image -> Trim
   d. Trim based on Transparent Pixels
   e. Trim away on all sides

2. **Export as Separate Layers** Each taxonomic classification is exported as its own individual layer, in which classifications are designated as pure red against a solid black background. Layers are then read separately, finding red vs black pixels to denote individual polygons representing individual colonies of a given classification.
   a. Select the magic wand tool
   b. Uncheck contiguous, so that all pixels of the same color designation will be selected
   c. Click on a color classification in the plot area that needs to be separated
   d. Create a new layer via cut (Ctrl+Shift+J). This will move all pixel selections to a separate layer
   e. Change the layer name to the appropriate taxonomic classification. **The name of the layer will become the filename for the taxonomic classification, check for typos!**
f. Continue until all designations are separated into individual layers
g. For each layer of taxonomic classifications, Ctrl+click the rectangular layer icon to select all nontransparent pixels
h. Set the foreground color to pure red (RGB:255,0,0)
g. Fill the selection using Edit-> Fill (Shft+F5)
h. Inverse the selection (Ctrl+Shft+I)
i. Set the foreground color to pure black (RGB:0,0,0)
j. Fill the selection using Edit-> Fill (Shft+F5)
k. Repeat for all layers
l. Create a new folder called PNGs where you wish to save the exported files
m. Turn on all layers to be exported
n. Select File-> Export-> Layers to files

For some versions of Photoshop, this will be File-> Scripts-> Export layers to files
   i. Change destination to PNGs folder
   iii. No file name prefix, check visible layers only
   iv. File type: PNG-24
   v. Check include ICC Profile
   vi. All PNG-24 Options unchecked

3. Export As a Single Layer For those with more advanced scripting skills, all classifications can alternatively be exported as a single PNG file. RGB values corresponding to each taxonomic classification will also need to be exported in order to match pixel colors to a particular taxa
   a. Save as PNG
   b. Select Small/compressed
   c. Interlace: None (Unchecked)
5.9 Analyzing Data

There are many programs which can be used for analysis of the annotated layers: ImageJ, R, Python, ArcGIS©, and Matlab©. Here we present a workflow using ImageJ to generate csv files containing information on each patch of pixels (i.e. a colony) such as area (px), local coordinates, perimeter, longest diameter, etc. It is up to the user's discretion to determine what metrics are of interest to extract.

1. Download ImageJ Fiji
   a. https://fiji.sc/#download

2. Option 1: Export data for individual files
   a. Import image file to Fiji
      i. Drag and drop the file into Fiji
      ii. File -> Open -> [select file]
   b. Image -> Type -> 8-bit
   c. Image -> Adjust -> Threshold
      i. Move slider in window box past the peak. Colors of colonies should be red and not grey
      ii. Hit Apply
   d. Analyze -> Set Measurements.
      i. Select measurements to include at user's discretion:
         1. Area
         **The area given is in pixels. For each file you will need to know the number of pixels per meter to determine the correct area (m²)**
         2. Centroid
         3. Perimeter
         4. Feret's diameter
         5. Display label
         6. Invert Y coordinates
   e. Analyze -> Analyze particles
      i. Only the following boxes should be checked
         1. Display results
         2. Clear results
         3. Add to Manager
   f. Save results
      i. In Results Window
         1. File -> Save As
         2. Name with site name and species

3. Option 2: Batch process all PNGs in folder
   a. Plugins -> Macros -> Startup Macros…
b. File -> New
c. Language -> IJ1 Macro
d. Paste the following text

```java
input = "E:/Location/of/PNG/Files/";
output = "E:/Location/where/csv/files/will/be/saved/";

setBatchMode(true);
list = getFileList(input);
for (i = 0; i < list.length; i++)
    action(input, output, list[i]);
setBatchMode(false);

function action(input, output, filename) {
    open(input + filename);
    run("8-bit");
    setAutoThreshold("Default dark");
    //run("Threshold...");
    setThreshold(85, 255);
    call("ij.plugin.frame.ThresholdAdjuster.setMode", "Red");
    run("Convert to Mask");
    //run("Close");
    run("Set Measurements...", "area centroid perimeter feret's display invert redirect=None decimal=3");
    run("Analyze Particles...", "display clear add");
    selectWindow("Results");
    saveAs("results", output + filename + ".csv");
    close();
    run("Clear Results");
}
```
e. Edit input and output to the working directory containing the png files and location where the exported csv files will be saved respectively
f. Edit metrics to be extracted as needed
   i. run("Set Measurements...", "area centroid perimeter feret's area_fraction display invert redirect=None decimal=3");
   ii. The script above will export the measurements listed above under Option A

g. Click “Run” button to analyze images
h. (Optional) Save batch script for future use
Appendix I

Single Camera Setup with GoPro

In adverse conditions (i.e. strong current or surge), photomosaics can still be collected using only the 18mm camera and housing. The mosaic rig is setup such that removal of the 18mm housing can be done easily and quickly between dives.

1. For the single camera setup, the 18mm camera is used to ensure maximum overlap.

2. To remove the 18mm camera housing from the rig, first the 55mm camera needs to be removed from the rig.

3. Remove the 55mm camera by loosening its associated wingnut at the bottom end of the rig and sliding the camera out from its slider tracks.

4. Once you have removed the 55mm camera, the small mounting wingnut for the 18mm camera can be accessed. Loosen this wingnut and slide the 18mm camera out.

5. The next step is to attach the GoPro directly to the 18mm camera housing.

6. The top of the Ikelite housing features a ¼"-20 threaded mounting point. Attach the 4" ¼"-20 all-thread stainless steel rod to this point.

7. Using a Tri-pod GoPro mount, attach a go pro to the other end of the threaded rod.

8. The handles should remain attached to the housing. The same swim pattern and speed described in the dual camera system should be maintained.

9. It is much more difficult to keep the single camera setup level and it is recommended that you attach a level to one of the handles.
## Appendix II

### Mosaic Hardware

<table>
<thead>
<tr>
<th>Qty</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Wing nut (short)</td>
<td>3&quot; long wing nut</td>
</tr>
<tr>
<td>1</td>
<td>Wing nut (long)</td>
<td>4&quot; long wing nut</td>
</tr>
<tr>
<td>12</td>
<td>Frame bolts</td>
<td>18-8 Flathead Stainless Steel Phillips Flat Head Screws, 3/8&quot;-16 Thread Size, 1-1/2&quot; Long</td>
</tr>
<tr>
<td>4</td>
<td>Handle screw &amp; washer</td>
<td>12-24 x 1/2-inch stainless steel screws</td>
</tr>
<tr>
<td>4</td>
<td>Laser bolt &amp; washer (optional)</td>
<td>Super-Corrosion-Resistant 316 Stainless Steel Socket Head Screw, 1/4&quot;-20 Thread Size, 1&quot; Long</td>
</tr>
<tr>
<td>8</td>
<td>Camera mounting plate screw</td>
<td>18-8 Stainless Steel Phillips Flat Head Screws, 1/4&quot;-20 Thread Size, 1/2&quot; Long</td>
</tr>
<tr>
<td>12</td>
<td>White slider track screws</td>
<td>18-8 Stainless Steel Phillips Flat Head Screws, 1/4&quot;-20 Thread Size, 1&quot; Long</td>
</tr>
<tr>
<td>16</td>
<td>Laser plate/column screw &amp; lock nut</td>
<td>18-8 Stainless Steel Phillips Flat Head Screws, 1/4&quot;-20 Thread Size, 1-3/4&quot; Long</td>
</tr>
<tr>
<td>1</td>
<td>GoPro tripod mount &amp; screw (optional)</td>
<td>18-8 Stainless Steel Phillips Flat Head Screws, 1/4&quot;-20 Thread Size, 3/4&quot; Long</td>
</tr>
<tr>
<td>1</td>
<td>GoPro all-thread mount (optional)</td>
<td>316 Stainless Steel Fully Threaded Stud, 1/4&quot;-20 Thread, 4&quot; Long</td>
</tr>
</tbody>
</table>
Appendix III

Plot Metadata Sheet
<table>
<thead>
<tr>
<th>Task Completed</th>
<th>Diver</th>
<th>Bottom Time</th>
<th>Dive #</th>
<th>Latitude (N/S)</th>
<th>Longitude (E/W)</th>
<th>Waypoint ID</th>
<th>GPS #</th>
<th>She</th>
<th>Ship</th>
<th>Date/Time Local</th>
<th>Date/Time UTC</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Scripps Institution of Oceanography
Dive and Navigation Information

Sandin Lab
Appendix V

Calibration Sheet
Appendix VI

Calibration Target
Appendix VII

Grid R Code

setwd("\"") #change to desired workspace

picname="Image_name" #change to desired filename
picture_W=#
picture_H=#

meter_pixel=#

#define the size of the box in meter
boxsize=0.5
meter_pixel=meter_pixel*boxsize

decimeter=meter_pixel/(10*boxsize)
# number of cells
length=floor(picture_H/meter_pixel)
width=floor(picture_W/meter_pixel)

#set width of line (do not change)
p=0.2

df(paste('grid_',picname,'.pdf',sep=""),width=width,height=length) #define the size of the df
plot(1,1,xlim=c(0,picture_W),ylim=c(0,picture_H),type='l',axes=T,xlab='Width',ylab='Height',las=1)

#the number and letters
for(j in 1:min(c(length*10,width*10)))  {
abline(h=meter_pixel*(j), col = 'grey',lwd=2.5)
abline(v=meter_pixel*(j), col = 'grey',lwd=2.5)
}
for(j in 1:min(c(length*10,width*10)){
for(i in 1:max(c(length*10,width*10))){
text(i*decimeter,meter_pixel*(j), letters[j], col = 1,srt=0,cex=p)
text(meter_pixel*(j),i*decimeter, j, col = 1,srt=0,cex=p,srt=0)
}

#external frame in red
abline(h=0,col=2)
abline(v=0,col=2)
abline(h=picture_H,col=2)
abline(v=picture_W,col=2)
dev.off()